HDD Health overview

What is HDD Health and what can it do

HDD Health utility for controlling the health status of your hard disks. HDD Health can discover a probable hard disk drive (HDD) fail BEFORE it actually occurs. In regular usage, HDD Health can calculate the nearest possible date of hard disk fail.

How does it work? HDD Health uses S.M.A.R.T. technology, included in all modern hard disks. S.M.A.R.T. is an HDD self-testing and monitoring technology described in detail here. Simplified, it looks like the HDD is continuously making self-tests and calculating some “attributes”, which reflect the current state of efficiency and status of the HDD. Each attribute means some detail in HDD status – total hours of work, count of read errors, and others. If after a self-test, the HDD "thinks" that its state is changed, it changes the value of the corresponding attribute. For example, if the time of spin-up from idle state changed, the HDD would change (lower) the value of the "Spin-Up Time" attribute. Each attribute has a threshold (lower) value and, at achievement, the HDD may stop working.

HDD Health monitors attribute changes, analyzes speed of falling (lowering), and calculates remaining time of life HDD based on this data.

Furthermore, HDD Health shows other useful information about your HDD - supported standards, speed modes of operation, current mode of operation (PIO, DMA, UDMA&ldots;), and others. Detailed info about these modes can be found under "HDD technology".

About HDD Health...

Overview
Installation

User interface

Main window
Brief Info tab
Extended Info tab
S.M.A.R.T. tab
Health tab
Log tab

Technical info

About S.M.A.R.T.
Basics of S.M.A.R.T.
Glossary

License

license

Support

support

Aleksey S Cherkasskiy
alexey@panterasoft.com
Copyright (c) PANTERASoft 1999-2003


Installation

HDD Health requires certain system drivers to be installed to function correctly. Windows 95/98/ME requires that SMARTVSD.VXD be installed and registered. This can be accomplished by allowing the installer to do it automatically by choosing typical setup. You can also copy the SMARTVSD.VXD file from the Windows 95/98 CD Rom to the Windows\System\Iosubsys directory. You will have to reboot the system.


Main window

The main window consist of three main parts:
- disks list (on top)
- main menu (at left)
- information area

The disks list gives information about all of the disk drives in the system.


General tab

General tab contains common (general) information about chosen HDD.

HDD information

- | Drive manufacturer
- | HDD model
- | Drive capacity
- | Serial number
- | Firmware revision number
- | Current Ultra DMA mode number (if supported)
- | S.M.A.R.T. compatibility
- | Drive's location in your system
- | Nearest T.E.C. date

Disk manufacturer

- | Disk manufacturer logo

Monitoring

- | Start date
- | Last check date
- | Nearest T.E.C. date


Extended Info tab

This tab contains detailed information about selected hard drive.


S.M.A.R.T. tab

S.M.A.R.T. details tab shows all available information about S.M.A.R.T. attributes of the chosen HDD.

It contains:

- | ID - attribute's ID number
- | Attribute - attribute description (short text description of attribute).
- | T.E.C. date - Threshold Exceeds Condition - supposed date when this attribute achieves threshold value, in other words probable date of end of HDD life. Prognosis of this date based on the factor "Speed of attribute change" (described above), so don't be surprised at variations of T.E.C. date, especially immediately after S.M.A.R.T. attribute change.
- | Value - current value of S.M.A.R.T. attribute
- | Threshold - threshold (critical) value of attribute - value, which disk manufacturer means as critical - an achievement of this value means that HDD fail is very probable.
- | Worst - worst attribute value - worst ever (lowest) value of this attribute during all life of this HDD. Use it only for information.
- | Changes - attribute value on the start monitoring


Health tab

Preferences Info tab

Here you can see information about the health status of the selected hard drive.

Precision
The "precision" bar shows you the pricision of the "Nearest T.E.C." date prediction. This precision depend on the monitoring time, attributes changes frequency and attributes values.

Known problems
This field shows a problems with selected hard drive. It can be a high temperature value, problems with IDE cable, problems with drive mechanics.

Overall health status
This field shows a current overall health status for selected hard drive.

Nearest T.E.C.
This field shows a nearest T.E.C. date for selected hard drive.


Log tab

The Log tab contains information such as the time HDD Health was started, and all alerts reported. Once an alert is occured, HDD Health logs the event date and time, the HDD model, capacity and serial number. The disk quota alerts are also recorded in the log along with all remote messaging notifications and failures.


S.M.A.R.T. overview

Self Monitoring And Reporting Technology (S.M.A.R.T.) is a major step to the truly fault tolerant computing environment. As all of us know that the Hard Disk Drive's, (HDD) in our servers, workstations or even home computers hold vast amounts of critical data. The HDD also has the greatest potential for failure of any component in a system. To date we could check a system for “soft errors” like cross linked files or lost clusters, we could scan for viruses and check the surface of the drives platters for defects, but there was really no reliable way to detect hardware failure.

Of course after the fact there are some diagnostics to check the drive out, but alas, our precious data is gone. S.M.A.R.T. on the other hand, monitors the drive's hardware performance with drive specific tests on the controller. When a fault is detected, a notification is given that the hardware may fail and all data should be backed up immediately and the drive sent for repair or replacement.

S.M.A.R.T. compliant drives are the norm, and have been shipping for several years now, and almost all drives available today are S.M.A.R.T. compliant. S.M.A.R.T. is defined and endorsed by the Small Form Factor (SFF) Committee, which includes Compaq Computer Corporation, Hitachi, Ltd., IBM Storage Products Company, Maxtor Corporation, Quantum Corporation, Seagate Technology, Toshiba Corporation and Western Digital Corporation among others. In fact, IBM has shipped nearly 3 million S.M.A.R.T. compliant drives, which have logged over 20 billion hours. S.M.A.R.T. is an industry standard reliability prediction indicator for both IDE/ATA and SCSI HDD.


Basics of S.M.A.R.T.

S.M.A.R.T. is actually a failure predication method based on a device varying from a defined set of thresholds. The idea is an industry wide continuation of PFA (predictive failure analysis) implemented and invented by IBM for its mainframe computers. The first company to implement S.M.A.R.T. technology on desktop PC's was Compaq Computer with their DFP (drive failure prediction).

A drive that is S.M.A.R.T. compliant has a series of tests embedded on the controller of the HDD. The data is constantly collected and monitored for variations within vendor specific thresholds. These tests are designed to predict the impending degradation or failure of a drive. For instance, if a drive is designed to spin at 3500 RPM and the manufactures threshold is +/- 100 RPM, the drive may be within threshold for a year, but as the drive ages the RPM's begin to fluctuate and before long are at 3300 RPM. Once that happens, an error is logged and a message is sent to the System Administrator and/or the user. The drive can now be scheduled for replacement before the condition gets worse and becomes catastrophic.

The various tests and thresholds that govern pass or fail are vendor specific and usually proprietary. The type of failures monitored by SMART include head and servo issues which result in read and seek errors, motor failure or bearing problems that result in spin up problems, excessive bad sectors and thermal testing. The faults are categorized into predictable and unpredictable, with the unpredictable usually being catastrophic. Unpredictable faults are normally electronics related or caused by static electricity or from handling. Testing and data collection can be in an on-line or off-line mode.

In the on-line mode, data is collected during idle times.

In the off-line mode the drive is required to respond to commands directly from the host and interrupt any operations.

HDD Health has automatic settings for monitoring the drive in on-line status as well as test now button for immediate off-line testing and data collection where supported. In order to make the implementation of S.M.A.R.T. practical, the system has to be able to alert the user, or in the case of a network, the system administrator of a potential failure.

To date the only way to utilize the S.M.A.R.T. technology is through the newer BIOS or with a simple desktop application that notifies the user of a failure. Most of these utilities are manufacturer specific and run under DOS. We go a step further. HDD Health runs natively under Windows 95/98/ME/NT/2000/XP and has easy to use messaging options where notifications can be sent via e-mail, network.

HDD Health also monitors more than two physical drives, and in fact can monitor all of the drives in your system.


Glossary

Attribute
Attributes are the specific performance or calibration parameters that are used in analyzing the status of the HDD. Attributes are selected by the device manufacturer based on that attribute’s ability to contribute to the prediction of degrading or fault conditions for that particular device. The specific set of attributes being used and the identity of these attributes is vendor specific and proprietary.

Attribute value
Attribute values are used to represent the relative reliability of individual performance or calibration attributes. The valid range of attribute values is from 1 to 253 decimal. Higher attribute values indicate that the analysis algorithms being used by the device are predicting a lower probability of a degrading or fault condition existing. Accordingly, lower attribute values indicate that the analysis algorithms being used by the device are predicting a higher probability of a degrading or fault condition existing.

Attribute threshold
Each attribute value has a corresponding attribute threshold limit which is used for direct comparison to the attribute value to indicate the existence of a degrading or fault condition. The numerical value of the attribute thresholds are determined by the device manufacturer through design and reliability testing and analysis. Each attribute threshold represents the lowest limit to which its corresponding attribute value can be equal while still retaining a positive reliability status. Attribute thresholds are set at the device manufacturer’s factory and cannot be changed in the field. The valid range for attribute thresholds is from 1 through 253 decimal.

Threshold exceeded condition (T.E.C.)
If one or more attribute values are less than or equal to their corresponding attribute thresholds, then the device reliability status indicates an impending degrading or fault condition.


License

HDD Health by Aleksey S Cherkasskiy, PANTERASoft.Com
License for use and distribution.

1. All copyrights to HDD Health are exclusively owned by Aleksey S Cherkasskiy, PANTERASoft.Com.

2. This version of HDD Health is freeware. It may be freely distributed, as long provided the distribution package is not modified. No person or company may charge a fee for the distribution of HDD Health without written permission from the copyright holder.

3. HDD Health IS DISTRIBUTED "AS IS". NO WARRANTY OF ANY KIND IS EXPRESSED OR IMPLIED. YOU USE AT YOUR OWN RISK. PANTERASOFT WILL NOT BE LIABLE FOR DATA LOSS, DAMAGES, LOSS OF PROFITS OR ANY OTHER KIND OF LOSS WHILE USING OR MISUSING THIS SOFTWARE.

4. You may not use, copy, emulate, clone, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer, or transfer the program, or any subset of the program, except as provided for in this agreement. Any such unauthorized use shall result in immediate and automatic termination of this license and may result in criminal and/or civil prosecution.

All rights not expressly granted here are reserved by Aleksey S Cherkasskiy, PANTERASoft.Com.

5. Installing and using HDD Health signifies acceptance of these terms and conditions of the license.

6. If you do not agree with the terms of this license you must remove HDD Health files from your storage devices and cease to use the product.

Thank you for using HDD Health
Aleksey S Cherkasskiy, PANTERASoft.Com
alexey@panterasoft.com

Copyright (c) PANTERASoft 1999-2002


Support

Before you contact us, please do the following:

- Be sure that you're doing everything right. We all make mistakes sometimes… Be attentive.

- Look at the Help file: it may already contain an answer to your question. A lot of people ask us something like "how do I…", though the complete information is there (in the document you're reading now).

- Visit HDD Health home page in the Internet at http://www.panterasoft.com. It's a good chance that you'll find the newer version of HDD Health there; we're trying to update the program once a month or even more frequently - when our staff is not on vacations, of course. Also, if the serious bug has been found in the program, but the new version is not ready yet, we make the hot fix for it.

- Visit our forum at http://www.panterasoft.com

But if you still have a problem with HDD Health and noting else helps, please contact technical support staff at:

support@panterasoft.com

Please inform us about the following:
- HDD Health version (from main window caption)
- where did you get HDD Health (http or ftp site)
- Windows 95/98/NT version (including service packs and other fixes installed), US or international, OEM or not
- computer information: CPU type and speed, amount of memory installed
- description of your problem (as much information as possible to retrieve the problem)

In order to get the complete computer information (working under Windows 95), open the Control Panel, click on "System" applet and press "Print" on "Device Manager" tab.
We'll try to help you as fast as possible, usually in one or two business days.

If you have any comments or suggestions for the next releases, please feel free to post them to us.


HDD Health overview

HDD Health utility for controlling the health status of your hard disks. HDD Health can discover a probable hard disk drive (HDD) fail BEFORE it actually occurs. In regular usage, HDD Health can calculate the nearest possible date of hard disk fail.

How does it work? HDD Health uses S.M.A.R.T. technology, included in all modern hard disks. S.M.A.R.T. is an HDD self-testing and monitoring technology described in detail here. Simplified, it looks like the HDD is continuously making self-tests and calculating some “attributes”, which reflect the current state of efficiency and status of the HDD. Each attribute means some detail in HDD status – total hours of work, count of read errors, and others. If after a self-test, the HDD "thinks" that its state is changed, it changes the value of the corresponding attribute. For example, if the time of spin-up from idle state changed, the HDD would change (lower) the value of the "Spin-Up Time" attribute. Each attribute has a threshold (lower) value and, at achievement, the HDD may stop working.

HDD Health monitors attribute changes, analyzes speed of falling (lowering), and calculates remaining time of life HDD based on this data.

Furthermore, HDD Health shows other useful information about your HDD - supported standards, speed modes of operation, current mode of operation (PIO, DMA, UDMA), and others. Detailed info about these modes can be found under "HDD technology".
Copyright (c) PANTERASoft 1999-2002